URL Filter

Post Reply
User avatar
RalfKerkhoff
Ssr. Bludit
Posts: 17
Joined: Sun Jan 03, 2021 11:16 am

Hi,
on the advanced settings tab I have set up the url filter for pages:
/articles/

When I now open the homepage of my webseite it shows me : Page not found

Reverting to the default / setting, make the content shown.

How can I manage to avoid the "Not found" message on the homepage with the url filter active?

Cheers
Ralf
lightmat
Sr. Bludit
Posts: 35
Joined: Fri Feb 21, 2020 10:53 pm

You need to use /blog/ for now
Edi explains here: viewtopic.php?p=9320#p9320
User avatar
RalfKerkhoff
Ssr. Bludit
Posts: 17
Joined: Sun Jan 03, 2021 11:16 am

Tried this multiple times. With changing the page url from '/' to something like /articles/ and defining a static page as a "Blog" page, will still show the "not found " error.

You can reproduce it on the bludit demo site. Simply change the page-url-filter to something different than the default '/' and then go to the website...

Ralf
User avatar
Edi
Site Admin
Posts: 2229
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

RalfKerkhoff wrote: Tue Jan 12, 2021 11:39 am Tried this multiple times. With changing the page url from '/' to something like /articles/ and defining a static page as a "Blog" page, will still show the "not found " error.
As I explained only /blog/ works as URL for the blog on a static page at the moment. To be clear: /blog/ as filter (set by default) and blog as friendly URL. But you can give the page (with the friendly URL blog) for example the title "Articles".
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
RalfKerkhoff
Ssr. Bludit
Posts: 17
Joined: Sun Jan 03, 2021 11:16 am

Hi,
i understand it for a static page serving as the homepage.
This works withoud problems.

What not works, is when you set the "page url filter" (the first one in the list of url filters) to something other than the default value of "/".

Doing so will display a "page not found" when opening the homepage.
This is also true when setting up a static page as a homepage.

Ralf
User avatar
diego
Site Admin
Posts: 751
Joined: Sat May 16, 2015 2:53 pm
Contact:

Hi,
any of the filters works for you ?
User avatar
RalfKerkhoff
Ssr. Bludit
Posts: 17
Joined: Sun Jan 03, 2021 11:16 am

Hi diego,

yes - all other filters (category, tags, blog) are working. it is only the filter for the pages that is not working.

Do I need to edit the htaccess file to get this working?

I have tried this on the bludit demo page and set a filter for the pages there. just to make sure that it is not my installation.
Same result on the demo page: Opening the bludit homepage will result in a "page not found".

Cheers
Ralf
Post Reply