Page 1 of 1

Cannot change theme

Posted: Mon May 22, 2023 1:16 am
by CarlSeiler
Using Bludit 3.13.1 Pro

Following instructions at I click on "Activate" on a theme, the screen responds with a little blue "The changes have been saved." However, nothing really happens. The former theme is shown to be the active one (by lack of "Activate") and when I look at the page, nothing has changed. Is there something I'm missing?

I'm going to install 3.14.1 to see.

Re: Cannot change theme

Posted: Mon May 22, 2023 2:18 am
by CarlSeiler
OK, I installed 3.14.1 pro, and the same issue is occurring, but I see what the real problem is that no changes in the Admin panel are actually taking place. That is, I change any setting, and they don't seem to stick. This includes changing themes.

This makes me wonder if I need to use chmod to change the permissions for the files. I don't think I've changed anything in years, and it used to work, but clearly things don't work now. It is currently set to 0751. Is there a recommendation? I see the install.php mentions 0755, so I'll try that and see if that's it. (Nope, that's not it...changed to 755 and performs the same.)

Re: Cannot change theme

Posted: Mon May 22, 2023 4:12 am
by CarlSeiler
So I tarred up the whole directory and reinstalled from scratch. When the install script runs, it tells me "Missing file, upload the file .htaccess" but .htaccess is sitting right there.

It also says "Writing test failure, check directory 'bl-content' permissions." Everything is at 0755.

I restored from my tar, and I'm back where I started from. Can see my Bludit, but cannot modify anything.

Re: Cannot change theme

Posted: Mon May 22, 2023 11:02 am
by Edi
Can you modify default content or publish new one?

Where do you host your installation?

Re: Cannot change theme

Posted: Mon May 22, 2023 4:31 pm
by CarlSeiler
It's like the whole thing is read-only, despite me running chmod -R 0755 on the bludit directory, and making sure that the .htaccess file is edited to point to /bludit/ on line 9.

I am not able to edit previously created content, nor am I able to create new content.

I'm hosted at We're running NetBSD 9.3 and PHP 8.1.18. The recent upgrades (as we used to run 5.6x), I thought might have killed something off, but that's why I tried wiping it and reinstalling.

I just did chmod -R 0771 and that got things working.

I'm thinking apache is in the nobody group, and needs to be able to write to files, and somewhere along the line I lost those permissions, and me applying 0751 or 0755 was not enough. Obv, in retrospect, I should have realized this, as apache would need to write, but I think I need to work out what optimal permissions need to be.

I appreciate your response as I worked it out.

Re: Cannot change theme

Posted: Mon May 22, 2023 10:51 pm
by Edi
Thank you for your feedback!

It seems that the installation has not given the right permissions.

How have you uploaded Bludit?