Bludit v4 - Alpha version

wmcig
Ssr. Bludit
Posts: 18
Joined: Tue Jun 20, 2017 5:32 pm

Edi wrote: Fri Nov 05, 2021 5:28 pm Which version of PHP do you use?

Shows the log file any errors?
Php version:

Code: Select all

 php --version
PHP 7.4.25 (cli) (built: Oct 23 2021 21:53:50) ( NTS )
Copyright (c) The PHP Group
Zend Engine v3.4.0, Copyright (c) Zend Technologies
    with Zend OPcache v7.4.25, Copyright (c), by Zend Technologies 
Which logfile do you need?
wmcig
Ssr. Bludit
Posts: 18
Joined: Tue Jun 20, 2017 5:32 pm

The logfiles do not show any errors.
User avatar
Edi
Site Admin
Posts: 2559
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Here are the informations about using Nginx in the documentation:

https://docs.bludit.com/en/webservers/nginx

If this does not help I will ask Diego, the developer, to have a look at it.
Planet Bludit, Tipps, Snippets und nützliche Links.
Image
wmcig
Ssr. Bludit
Posts: 18
Joined: Tue Jun 20, 2017 5:32 pm

Edi wrote: Mon Nov 08, 2021 9:04 pm Here are the informations about using Nginx in the documentation:

https://docs.bludit.com/en/webservers/nginx

If this does not help I will ask Diego, the developer, to have a look at it.
I tried it several times. I put the conf-file into each time in several folders: "/etc/nginx/ sites-enabled", "/etc/nginx/sites-available", "etc/nginx/conf.d".

Nothing helped. Everytime there was the error "404 not found nginx". But in the address line of the browser I could see "http://192.168.178.40/bludit/willkommen-bei-bludit", after I clicked on the title of the post on the page.
User avatar
Edi
Site Admin
Posts: 2559
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Is the module ngx_http_rewrite_module enabled?
Planet Bludit, Tipps, Snippets und nützliche Links.
Image
wmcig
Ssr. Bludit
Posts: 18
Joined: Tue Jun 20, 2017 5:32 pm

I am using bludit.conf in folder "etc/nginx/conf.d"

I have enabled the mod_rewrite for subfolder bludit.

Code: Select all

GNU nano 5.4                     bludit.conf
server {
    listen 80;
    server_name example.com;
    root /www/bludit;
    index index.php;

    access_log /var/log/nginx/example.log;
    error_log /var/log/nginx/example.log;

    location ~ \.(jpg|jpeg|gif|png|css|js|ico|svg|eot|ttf|woff|woff2|otf)$ {
        access_log        off;
        expires           30d;
    }

    location ~ \.php$ {
        fastcgi_pass    unix:/run/php/php-fpm.sock;
        fastcgi_index   index.php;
        include         fastcgi.conf;
    }

    location /bludit {
        try_files $uri $uri/ /bludit/index.php?$args;
    }

    location ^~ /bl-content/databases/ { deny all; }
    location ^~ /bl-content/workspaces/ { deny all; }
    location ^~ /bl-content/pages/ { deny all; }
    location ^~ /bl-kernel/*.php { deny all; }
}
It does not work.
Post Reply