Plugins stören die Webseite

User avatar
janiekmulder
Master Bludit
Posts: 88
Joined: Sun Jun 28, 2020 2:21 pm

Hallo zusammen,

ich bin ein Neuling in Sachen Bludit und versuche herauszufinden, ob Bludit für mich die richtige Wahl sein könnte. Ich suche nach einer schlanken Bloglösung und hoffe, mit Bludit diese gefunden zu haben. Der erste Eindruck bestätigt dies.

Die von mir installierte Version ist 3.12.0

Als Editor nutze ich das Plugin TinyMCE in der Version 5.2.0, welcher nach der Installation bereits aktiviert war. Ansonsten hätte ich diesen Editor selber hereingebracht. Ich finde ihn gut.

Als Theme nutze ich Andy in der Version 0.1.0

Nun möchte ich noch zwei weitere Plugins nutzen. Und zwar:

- lightbox 1.2
- media 0.1.1

Beide Plugins habe ich von der Plugin-Seite heruntergeladen.

Und beide Plugins funktionieren nicht oder nicht so wie ich es gerne hätte.

Lightbox

Sobald ich den Ordner für Lightbox in das Plugin-Verzeichnis auf dem Server kopiere, wird im Editor TinyMCE nur noch die Möglichkeit geboten, die Text im Quelltext-Modus zu schreiben. Der WYSIWYG-Modus wird nicht mehr aufgerufen. Es spielt auch keine Rolle, ob das Plugin aktiviert ist. Es reicht das Vorhandensein im Plugin-Ordner. Im englischsprachigen Teil ist bereits ein Thema im Gange, aber ich kann es nicht gut verstehen.

Als Fehlermeldung wird mir in der Konsole folgendes angezeigt:
tinymce.min.js?version=5.2.0:9 Failed to initialize the editor as the document is not in standards mode. TinyMCE requires standards mode.
uh @ tinymce.min.js?version=5.2.0:9
(anonymous) @ tinymce.min.js?version=5.2.0:9
e @ tinymce.min.js?version=5.2.0:9
Zr.executeHandlers @ tinymce.min.js?version=5.2.0:9
o @ tinymce.min.js?version=5.2.0:9
i @ tinymce.min.js?version=5.2.0:9
jquery.min.js?version=3.12.0:2 jQuery.Deferred exception: Cannot read property 'getContent' of null TypeError: Cannot read property 'getContent' of null
at editorGetContent (https://www.janiek.de/bludit/admin/new-content:856:33)
at HTMLDocument.<anonymous> (https://www.janiek.de/bludit/admin/new-content:818:23)
at e (https://www.janiek.de/bludit/bl-kernel/ ... .0:2:29453)
at t (https://www.janiek.de/bludit/bl-kernel/ ... .0:2:29755) undefined
k.Deferred.exceptionHook @ jquery.min.js?version=3.12.0:2
t @ jquery.min.js?version=3.12.0:2
setTimeout (async)
(anonymous) @ jquery.min.js?version=3.12.0:2
c @ jquery.min.js?version=3.12.0:2
fireWith @ jquery.min.js?version=3.12.0:2
fire @ jquery.min.js?version=3.12.0:2
c @ jquery.min.js?version=3.12.0:2
fireWith @ jquery.min.js?version=3.12.0:2
ready @ jquery.min.js?version=3.12.0:2
B @ jquery.min.js?version=3.12.0:2
jquery.min.js?version=3.12.0:2 Uncaught TypeError: Cannot read property 'getContent' of null
at editorGetContent (new-content:856)
at HTMLDocument.<anonymous> (new-content:818)
at e (jquery.min.js?version=3.12.0:2)
at t (jquery.min.js?version=3.12.0:2)
Media

Hier verhält es sich so, dass, sobald der Ordner des Plugins in den Plugin-Ordner auf dem Server kopiert wird, die komplette Seite nicht mehr angezeigt wird. Nichts geht mehr.

Als Fehlermeldung wird mir in der Konsole folgendes angezeigt:
Failed to load resource: the server responded with a status of 500 (Internal Server Error)
Dazu habe ich bislang noch nichts finden können, um ggfs. dem Fehler auf die Spur zu kommen und möglicherweise bei mir etwas richtigstellen zu können.

Die beiden Plugins sind mehr oder weniger ein must-have und daran entscheidet sich tatsächlich, ob ich Bludit werde nutzen wollen für mein Vorhaben.

Sind die Probleme auch anderen Nutzer bekannt und schon in der Diskussion?

Schönen Gruß
Janiek
User avatar
Edi
Site Admin
Posts: 2540
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

janiekmulder wrote: Sun Jun 28, 2020 2:43 pm
Lightbox

Sobald ich den Ordner für Lightbox in das Plugin-Verzeichnis auf dem Server kopiere, wird im Editor TinyMCE nur noch die Möglichkeit geboten, die Text im Quelltext-Modus zu schreiben.
Da scheint ein Bug zu sein. Ich muss mir das ansehen.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
Edi
Site Admin
Posts: 2540
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Der Fehler ist behoben, das aufdatierte Plugin steht zum Download bereit.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
Edi
Site Admin
Posts: 2540
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

janiekmulder wrote: Sun Jun 28, 2020 2:43 pm Media

[...]

Dazu habe ich bislang noch nichts finden können, um ggfs. dem Fehler auf die Spur zu kommen und möglicherweise bei mir etwas richtigstellen zu können.
Findet sich vielleicht im Error Log des Servers etwas dazu?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
janiekmulder
Master Bludit
Posts: 88
Joined: Sun Jun 28, 2020 2:21 pm

Edi wrote: Sun Jun 28, 2020 5:52 pm Der Fehler ist behoben, das aufdatierte Plugin steht zum Download bereit.
Das Plugin Lightbox stört nun TinyMCE nicht mehr. Herzlichen Dank für die schnelle Lösung des Problems. :P

Jetzt muss ich nur noch mit der Lightbox umgehen lernen.
User avatar
janiekmulder
Master Bludit
Posts: 88
Joined: Sun Jun 28, 2020 2:21 pm

Edi wrote: Sun Jun 28, 2020 5:59 pm
janiekmulder wrote: Sun Jun 28, 2020 2:43 pm Media

[...]

Dazu habe ich bislang noch nichts finden können, um ggfs. dem Fehler auf die Spur zu kommen und möglicherweise bei mir etwas richtigstellen zu können.
Findet sich vielleicht im Error Log des Servers etwas dazu?
Leider nicht wirklich. Das ist der Auszug zum Aufrufzeitpunkt aus der Log-Datei von Apache 2:
xx.xxx.xx.xx - - [28/Jun/2020:18:13:14 +0200] "-" 408 137 "-" "-"
xx.xxx.xx.xx - - [28/Jun/2020:18:13:27 +0200] "GET /bludit/ HTTP/1.1" 500 351 "https://www.janiek.de/bludit/test-mit-seitenumbruch" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36"
Ich habe nur den Plugin-Ordner von Media 0.1.1 in den Plugin-Ordner auf dem Server kopiert. Und schon läuft die Seite nicht mehr.
Attachments
Screenshot_20200628_182337.png
Screenshot_20200628_182337.png (16.78 KiB) Viewed 3656 times
User avatar
Edi
Site Admin
Posts: 2540
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Versuche es bitte einmal mit folgendem Eintrag in der Datei .htaccess:

Code: Select all

# Base directory
RewriteBase /bludit/
statt

Code: Select all

# Base directory
RewriteBase /
Welche PHP-Version verwendest Du?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
janiekmulder
Master Bludit
Posts: 88
Joined: Sun Jun 28, 2020 2:21 pm

Edi wrote: Sun Jun 28, 2020 6:36 pm Versuche es bitte einmal mit folgendem Eintrag in der Datei .htaccess:

Code: Select all

# Base directory
RewriteBase /bludit/
statt

Code: Select all

# Base directory
RewriteBase /
Welche PHP-Version verwendest Du?
Den Eintrag in der .htaccess hatte ich bereits zu Beginn abgeändert, da ansonsten die Seite nicht geladen wurde.

Die PHP-Version ist: v7.0.33-1

Edit-Info

Auf dem lokalen Rechner ist die PHP-Version: v7.3.14-1

Dort macht das Plugin keine Probleme.

Ergo ist meine PHP-Version auf dem vServer das Problem?
User avatar
janiekmulder
Master Bludit
Posts: 88
Joined: Sun Jun 28, 2020 2:21 pm

janiekmulder wrote: Sun Jun 28, 2020 6:46 pm
Edi wrote: Sun Jun 28, 2020 6:36 pm
Welche PHP-Version verwendest Du?
Den Eintrag in der .htaccess hatte ich bereits zu Beginn abgeändert, da ansonsten die Seite nicht geladen wurde.

Die PHP-Version ist: v7.0.33-1

Edit-Info

Auf dem lokalen Rechner ist die PHP-Version: v7.3.14-1

Dort macht das Plugin keine Probleme.

Ergo ist meine PHP-Version auf dem vServer das Problem?
Die PHP-Version ist nun auf v7.4.7 aktualisiert worden. Es hat sich aber nichts geändert. Nach wie vor wird die Webseite nicht mehr angezeigt, sobald das Plugin in den Plugin-Ordner des Servers kopiert wurde.

Da brat mir doch einer einen Storch. :D

Der Apache2-Webserver ist in der Version Apache/2.4.10 (Debian) installiert.
SamBrishes
Master Bludit
Posts: 106
Joined: Tue Dec 25, 2018 8:07 pm

Hallow,

kannst du bitte einmal diese Version hier ausprobieren?

Danke.
Post Reply