Warum kommt ein noimage.png?

Post Reply
yakari
Master Bludit
Posts: 100
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 7 times
Been thanked: 4 times

In meinem, an sich gut funktionierenden Theme "Jupiter" (aus div. Teilen anderer Themes zusammengebastelt) habe ich plötzlich eine Datei namens ...\bl-themes\jupiter\img\noimage.png.

Keine Ahnung, wie diese Datei da hineinkommt.
(Ich kenne nur ein offizielles Theme, welches auch so eine Datei hat: "Kolika" Doch jenes Theme war keinesfalls Grundlage oder "Teile-Lieferant" für mein eigenes Theme.)
Nun, in "Kolika" stört dieses "noimage.png" nicht - in meinem schon.

Konkret zeigt es sich als 45x23 px kleiner, aber störender schwarzer Balken in jedem Beitrag.
Hat vllt. jemand eine Ahnung, warum das so ist? Welche Kriterien müssen erfüllt sein, dass ein "noimage" erscheinen muss?

Das zeigt sich im Quelltext, unterhalb des (korrekt angezeigten) Beitragbildes und oberhalb des Beitrag-Textes:

Code: Select all

<p class="d-block text-white">
              <img src=".../bl-themes/jupiter/img/noimage.png" alt="" width="45" height="45" class="rounded-circle"> &nbsp;            </p>
yakari
Master Bludit
Posts: 100
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 7 times
Been thanked: 4 times

Also der Code, welcher dieses "noimage.png" zeigt, sollte eigentlich das Profilbild des Autors zeigen.

Code: Select all

<img src="<?php echo ($page->user('profilePicture')?$page->user('profilePicture'):Theme::src('img/noimage.png')) ?>">
Das Profilbild ist definiert und in \bl-content\uploads\profiles vorhanden.
Dennoch kommt das "noimage".

Habe mir die hier zu findenden Foren-Beiträge zum Thema angesehen und versucht, das zu reparieren - kein Erfolg ...
z.B.:
viewtopic.php?p=12406#p12406
viewtopic.php?p=1941#p1941

Dabei verwirrt auch, das es einmal

Code: Select all

$page->user()
und dann

Code: Select all

$Post->user()
ist ...
yakari
Master Bludit
Posts: 100
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 7 times
Been thanked: 4 times

Ich geb's auf.
Nach 8 Stunden geht das immer noch nicht.
Wobei es andere Wege dafür gibt, das Benutzerbild samt Fallback einzubinden.
Doch es geht mir ums Verständnis, ums Prinzip.

Denn wenn man ums verr... nicht an '$Post' oder 'User()' herankommt, stimmt auch viel mehr nicht.
Nehme an, es hat mit den $WHERE_AM_I Sachen zu tun. Auch wenn man die Unterscheidung lt. dieser Seite (Pkt. 3.5 Inhalt) im Prinzip kapiert, dennoch schaffe ich es nicht ...

Selbst die einfachsten Codebeispiele, welche den 'User()' betreffen, funktionieren nicht:
viewtopic.php?p=1941#p1941
viewtopic.php?p=9678#p9678

Denn so wie bei dem habe ich das Problem, dass die Variable 'Post' nicht definiert ist:
viewtopic.php?p=3206#p3206
Daher geht auch keine

Code: Select all

$User = $Post->user();
Und die Beispiele mit

Code: Select all

$User = $page->user();
klappen schon gar nicht, obwohl die Variable 'pages' (im Gegensatz zu 'post') definiert sei.

Ich blicke nicht mehr durch und wenn man über 1 Jahr nicht im Code war, braucht man Hilfe, einen Anstoß, ... aber ...
wjar
Jr. Bludit
Posts: 6
Joined: Fri Dec 16, 2022 6:58 pm
Been thanked: 1 time

Selbst nutze ich das Profilbild nicht, aber im Theme Mediumish (https://themes.bludit.com/theme/mediumish) wird auch mit dem Platzhalterbild gearbeitet und dort funktioniert es (s. home.php des Themes). Vielleicht hilft Dir der Code dort weiter.
yakari
Master Bludit
Posts: 100
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 7 times
Been thanked: 4 times

wjar wrote: Sat Mar 30, 2024 8:15 am Theme Mediumish ... dort funktioniert es (s. home.php des Themes).
Danke.
Aber dort ist es genauso gelöst wie in
https://blthemes.com/kutanews-free-bludit-theme
https://blthemes.com/travelopedia-nice- ... ravel-blog
https://blthemes.com/kolika-free-theme-for-bludit
und wie in meinem.

Der Code (für das Profilbild + den Nickname (+ Fallback)) ist bei all den genannten Themes gleich:

Code: Select all

<img src="<?php echo ($page->user('profilePicture')?$page->user('profilePicture'):Theme::src('img/noimage.png')) ?>">  
Aber:
Auch beim Mediumish Theme von Diego höchstpersönlich funktionieren die Profilbilder und der Nickname nur in einigen Beiträgen. Sowohl in der Startseiten-Vorschau als auch beim Beitrag selbst (wo nur der Nickname ausgeben werden soll) gilt: Es geht nur manchmal.

Dabei gibt es keinen Unterschied: Alle Beiträge sind Standard (also weder statisch, noch fixiert), in der gleichen Kategorie usw.

Image

Der einzige Unterschied ist, dass bei den Beiträgen, wo alles (profilePicture + nickname) angezeigt wird, sich das Hauptbild nicht speichern lässt. Dies aber nur in den Einstellungen des Artikels > Allgemein > HAUPTBILD. Es wird zwar im Frontend angezeigt, ist aber im Backend nicht zu sehen.

In allen Beiträgen, wo sich das HAUPTBILD auch in den Einstellungen zeigt, funktioniert die Anzeige von profilePicture + nickname nicht.

Verwirrend das ist ...

---

Teillösung > Nachtrag:
Ich glaube, ich weiß, warum manche Beiträge weder Profilbild noch Nickname anzeigen:
Denn diese Angaben werden nur bei den selbst eingestellten Beiträgen angezeigt (Autor "Yakari")!
Bei den Beispiel-Beiträgen, welche vom System selbst angelegt wurden (Autor "Admin") kommt das Fallback Bild noimage.png und kein Autorenname.

Das ist mal sicher.
Jetzt die hoffentlich letzte Frage zT.:
Wie könnte man den Autor nachträglich ändern? Nur in der "Datenbank" \bl-content\databases\pages.php ? Auch nicht elegant, oder?
Post Reply