Google Fonts, Awesone usw.

User avatar
Edi
Site Admin
Posts: 2858
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Has thanked: 21 times
Been thanked: 30 times
Contact:

yakari wrote: Tue Sep 20, 2022 8:02 pm Und trotz allen rauslöschen (ich suche die Codestellen per aborange searcher, dem entgeht nix) zeigen sich mir im Browser > Netzwerk Tab > Schriftarten stets mind 3 https://fonts.googleapis.com/ Einbindungen.

Wo könnten die herkommen, wie kriege ich die weg?
Wenn Du beispielsweise beim Theme Editorial den Link zu den Google-Fonts entfernst, werden die Links für die Fonts Open Sans und Roboto Slab und ihre Zuordnung in der CSS-Datei bei der Netzwerkanalyse nicht mehr angezeigt.
yakari
Sr. Bludit
Posts: 42
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 4 times

Ich glaube wir haben da ein Google Chrome Problem: Denn (nur?) der Browser scheint die Fonts nativ von dort zu holen.

Ich habe nun viele Websites, die garantiert frei von GF sind, und die Bludit Themes getestet: Im FF u. allen anderen Browsern ist alles ok!

Jetzt stellt sich nur die Frage, wie man das im Chrome abstellen kann?
User avatar
Edi
Site Admin
Posts: 2858
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Has thanked: 21 times
Been thanked: 30 times
Contact:

yakari wrote: Wed Sep 21, 2022 6:22 pm Jetzt stellt sich nur die Frage, wie man das im Chrome abstellen kann?
Das ist in der Tat sehr eigenartig.

Nachdem ich beim Theme Editorial in der CSS-Datei main.css die Anweisungen für die Familien der Google Fonts gelöscht habe, wird mir nichts mehr angezeigt. Warum das so ist, kann ich Dir im Moment nicht sagen. Es könnte aber mit dem Cache zu tun haben.
yakari
Sr. Bludit
Posts: 42
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 4 times

Edi wrote: Thu Sep 22, 2022 8:37 pm Es könnte aber mit dem Cache zu tun haben.
Nein, letzteres kann ich ausschließen. Egal auf welchen Rechner, egal ob alles aus dem Browser gelöscht, ja selbst bei einer Chrome Neuinstallation auf einem zuvor neu aufgesetzten PC - immer das gleiche.

Jemand nannte mir zur Lösung folgendes:
Right Click Chrome's launcher icon, click "Properties".
At the end of the launcher string add the following:
" --disable-remote-fonts" (without quotes).
Dh. also das Kommando in der Verknüpfung zur Chrome exe sollte so aussehen:

Code: Select all

"C:\Program Files\Google\Chrome\Application\chrome.exe" --disable-remote-fonts
Aber: Auch das hilft nix ...

Daher kann man, um sicherzugehen, nur (auch) mit einem anderen Browser testen.
In FF ist ja alles okay ...
yakari
Sr. Bludit
Posts: 42
Joined: Sun Apr 10, 2022 10:33 am
Has thanked: 4 times

Ursache gefunden:
Es war die Chrome Erweiterung "Lesezeichenleiste"
Stellt man deren Schriftart auf eine Schriftart um, welche in jedem OS sind, wie zB. Arial(Helvetiva), Times oder was auch immer um, dann verschwinden die 3 Google Fonts Einbindungen.

Warum es aber bei einer clean Neuinstallation auch dabei war? Keine Ahnung ... Wurst, hauptsache es ist weg.
Post Reply