Bludit v1.1 "The Dig"

User avatar
DarrenDriven
Master Bludit
Posts: 69
Joined: Thu Jan 07, 2016 9:39 am
Location: Portland OR
Contact:

Sun Feb 21, 2016 9:10 pm

Another question. The new image upload function... how do you get the image to embed into the new post? Before there was a button that said "insert image" or something like that, now when I upload an image it shows up as a thumbnail, but clicking, double-clicking or dragging doesn't seem to do anything.
User avatar
diego
Site Admin
Posts: 698
Joined: Sat May 16, 2015 2:53 pm
Contact:

Mon Feb 22, 2016 3:47 am

DarrenDriven wrote:Another question. The new image upload function... how do you get the image to embed into the new post? Before there was a button that said "insert image" or something like that, now when I upload an image it shows up as a thumbnail, but clicking, double-clicking or dragging doesn't seem to do anything.
When you click on the thumbnail image a menu is showed ?

https://docs.bludit.com/en/content/how- ... t-an-image

What browser do you used?
User avatar
DarrenDriven
Master Bludit
Posts: 69
Joined: Thu Jan 07, 2016 9:39 am
Location: Portland OR
Contact:

Mon Feb 22, 2016 5:36 am

I'm using the latest version of Firefox on a Windows 10 machine.

When I click on the thumbnail it just gets an orange highlight around it.

When I click on the "More images" button I get the popup, but the same thing happens and I can only make the thumbnail 's outline turn orange.

Also, when I view the previous day's scheduled post which I created under the 0.7.2 interface, I no longer get to see the image in a WYSIWYG style.

https://youtu.be/CDXeITdhoh4
User avatar
DarrenDriven
Master Bludit
Posts: 69
Joined: Thu Jan 07, 2016 9:39 am
Location: Portland OR
Contact:

Mon Feb 22, 2016 5:40 am

Hmmmm.... I just realized that the WYSIWYG buttons at the top of the main text area are missing. I went into plug-ins and activated the SimpleMDE plugin.

Now that I have done that, when I double-click the thumbnail I see action!

Code: Select all

![alt text](20160224b.jpg)
And I also discovered that the eyeball icon in the SimpleMDE menu toggles preview mode so I can see the post the way it would look on my blog.

My advice would be to enable SimpleMDE by default and also to enable the preview mode by default.
User avatar
DarrenDriven
Master Bludit
Posts: 69
Joined: Thu Jan 07, 2016 9:39 am
Location: Portland OR
Contact:

Mon Feb 22, 2016 6:59 pm

Hmmm... oops, you can't enable preview mode by default because you can't edit in preview mode. Oh well, not a big deal.
User avatar
diego
Site Admin
Posts: 698
Joined: Sat May 16, 2015 2:53 pm
Contact:

Tue Feb 23, 2016 3:22 am

mmm are you sure you have installed Bludit v1.1 ? because the tags selection have an old style from v1.0..
User avatar
DarrenDriven
Master Bludit
Posts: 69
Joined: Thu Jan 07, 2016 9:39 am
Location: Portland OR
Contact:

Tue Feb 23, 2016 4:20 am

Dang it. I somehow installed 1.0.2! I'm updated now.
User avatar
DarrenDriven
Master Bludit
Posts: 69
Joined: Thu Jan 07, 2016 9:39 am
Location: Portland OR
Contact:

Tue Feb 23, 2016 4:25 am

Noticing that in the CSS favicon is referenced at /bl-themes/future-imperfect/img/favicon.png

There is no /img/ folder in future-imperfect.
User avatar
diego
Site Admin
Posts: 698
Joined: Sat May 16, 2015 2:53 pm
Contact:

Tue Feb 23, 2016 4:59 am

Yes it's a bug the favicon and the insert image doesn work without the simplemde or tinymce, I will fix it.
User avatar
diego
Site Admin
Posts: 698
Joined: Sat May 16, 2015 2:53 pm
Contact:

Wed Feb 24, 2016 6:29 am

DarrenDriven wrote:Noticing that in the CSS favicon is referenced at /bl-themes/future-imperfect/img/favicon.png

There is no /img/ folder in future-imperfect.
Fixed!
- Bludit menu v8 fixed, to insert images without any HTML Editor
- Textarea new line when press enter
- Favicon on Future-imperfect theme

You can get the code from Github. https://github.com/dignajar/bludit/archive/master.zip

I will release a new version in a few days with this changes.
Post Reply