Blank Page when editing a Page

Post Reply
Achim
Jr. Bludit
Posts: 5
Joined: Sun Jan 17, 2021 6:24 pm

Hi.
New to Bludit, the installation went fine. Everything works and is in place except
editing a page.
I can successfully create a page, I can delete a page, but when I try to edit, I see a blank page where the editor and content should be.
That happens with default Themes as well as with modified Themes.
No hints in the logs.
Whats realy strange is that I can create and delete.

[edit] Server running FreeBSD 12.1, Caddy2.21 with php_fastcgi, PHP7.4.14, Bludit 3.13.1

The (maybe) only "special" on this setup is the use of Caddy as a Webserver.
Any ideas?

Thank you
Achim
User avatar
Edi
Site Admin
Posts: 2229
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Does the browser console show any errors?

Is there a firewall installed on the server?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Achim
Jr. Bludit
Posts: 5
Joined: Sun Jan 17, 2021 6:24 pm

Edi wrote: Sun Jan 17, 2021 7:09 pm Does the browser console show any errors?

Is there a firewall installed on the server?
Thanks for the answer.
No Firewall.
I just tried php -S ip adress:8000
Same problem. Pages are visible, can be created and deleted, but not edited.
User avatar
Edi
Site Admin
Posts: 2229
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

And: Does the browser console show any errors?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Achim
Jr. Bludit
Posts: 5
Joined: Sun Jan 17, 2021 6:24 pm

Here we go.
Your Hint regarding the Browser Console was the right path.
Console Errors pointed me to the missing php74-filter extension.
Maybe the need of "session" (which i already installed) and "filter" should be mentioned in the manual.

Anyway, thanks for your help.
And maybe, this helps other newbies as well.

Thanks again
Achim
User avatar
Edi
Site Admin
Posts: 2229
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Great!

Is this specific to Caddy?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
diego
Site Admin
Posts: 751
Joined: Sat May 16, 2015 2:53 pm
Contact:

Hi,
I was checking and the filter module is enabled by default.

https://www.php.net/manual/en/filter.installation.php

Maybe in your installation is disabled ?
Achim
Jr. Bludit
Posts: 5
Joined: Sun Jan 17, 2021 6:24 pm

Edi wrote: Sun Jan 17, 2021 10:10 pm Great!

Is this specific to Caddy?
I don't think so.
Caddy runs php without problems. Its not more than compiling php with fastcgi, puting
php_fastcgi 127.0.0.1:9000
into the Caddy config and maybe edit user:group in php-fpm.d (on FreeBSD its /usr/local/etc/php-fpm.d/www.conf
Restart and check <?php phpinfo(); ?>
Everything should work.
Last edited by Achim on Tue Jan 26, 2021 2:21 am, edited 1 time in total.
Achim
Jr. Bludit
Posts: 5
Joined: Sun Jan 17, 2021 6:24 pm

diego wrote: Mon Jan 18, 2021 9:56 am Hi,
I was checking and the filter module is enabled by default.

https://www.php.net/manual/en/filter.installation.php

Maybe in your installation is disabled ?
Diego, it was not disabled, the module was simply not installed.
Maybe its a bit specific compared to some Linux Distris or Hosting Companies.
On an clean fresh FreeBSD, you install php7.4 with FPM/CGI as an selectable option from (in my case) ports.
Its just php74, without any Modules/Extensions. Clean as usual on FreeBSD.
Now, you install the Modules from ports. One by one.
If a Module is missing because its not mentioned in the bludit Manual, php wont work proper with bludit.
Thats why I suggest to mention the two Modules (session and filter) in the Bludit Manual.
Achim
Post Reply