Urgent Issue with Deleting Page!

Post Reply
kolimbursi
Ssr. Bludit
Posts: 24
Joined: Tue Feb 11, 2020 10:00 am

Mon Apr 06, 2020 9:53 pm

Hello!

I am creating the website: http://wudangmartialarts.com/

And I found out that topics with special character & cause the admin panel to hang up. I am unable to delete the page.

My question is now - how can I delete the page manually? I deleted everything from bl-content/pages

but the page still shows - where can I delete it??

thanks for the quick help!

the page I have issue with: http://wudangmartialarts.com/register-visit
User avatar
Edi
Site Admin
Posts: 1846
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Mon Apr 06, 2020 10:05 pm

kolimbursi wrote:
Mon Apr 06, 2020 9:53 pm
And I found out that topics with special character & cause the admin panel to hang up.
What special characters cause this problem?
My question is now - how can I delete the page manually? I deleted everything from bl-content/pages

but the page still shows - where can I delete it??
You also have to delete the pages from the database file pages.php at /bl-content/databases.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
kolimbursi
Ssr. Bludit
Posts: 24
Joined: Tue Feb 11, 2020 10:00 am

Mon Apr 06, 2020 10:11 pm

thanks that worked!

for some reason when I save the page with the topic: "Register & Visit" - I was able to edit the page - but after saving it locked down and I was unable to edit or delete it.
User avatar
Edi
Site Admin
Posts: 1846
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Mon Apr 06, 2020 10:20 pm

kolimbursi wrote:
Mon Apr 06, 2020 10:11 pm
for some reason when I save the page with the topic: "Register & Visit" - I was able to edit the page - but after saving it locked down and I was unable to edit or delete it.
Thank you. I will have a look at it.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
kolimbursi
Ssr. Bludit
Posts: 24
Joined: Tue Feb 11, 2020 10:00 am

Mon Apr 06, 2020 10:30 pm

I did it two times to confirm it ... it locked up my page the second time too.
User avatar
Jay
Master Bludit
Posts: 106
Joined: Mon Feb 11, 2019 8:41 pm

Mon Apr 06, 2020 10:55 pm

Did you enable unicode in general settings -> seo?
kolimbursi
Ssr. Bludit
Posts: 24
Joined: Tue Feb 11, 2020 10:00 am

Mon Apr 06, 2020 11:23 pm

Yes, I did - maybe the thing is I use it on a Chinese server? It is one reason why I build this very lightweight website. Cause for foreigners this is usually loading very slow.
User avatar
Jay
Master Bludit
Posts: 106
Joined: Mon Feb 11, 2019 8:41 pm

Wed Apr 08, 2020 12:21 am

kolimbursi wrote:
Mon Apr 06, 2020 11:23 pm
Yes, I did - maybe the thing is I use it on a Chinese server? It is one reason why I build this very lightweight website. Cause for foreigners this is usually loading very slow.
If you only host your website on a chineese server but it isn't in chineese language, basically using unicode chars in urls is a bad idea. I won't get into details as there are plenty good articles about it.

I'm not 100% sure if that's a problem only with unicode url in bludit as I cannot recall if I hadn't run in similar problem with disabled unicode. It might have something to do with some special chars not transliterated to entities, thus making url invalid while parsing in php.
Let's say that I try not to touch cursed unicde urls option in any cms.

Either you
- try to disable unicode
- encode chars in title with special meaning to html entities ( like & -> &)
- use a temporary title, save article, then change title and custom url in articles options > seo > friendly url field
kolimbursi
Ssr. Bludit
Posts: 24
Joined: Tue Feb 11, 2020 10:00 am

Thu Apr 09, 2020 2:37 pm

thanks! Yes, I will try to avoid this! I was not aware that this can cause an issue.
Post Reply