Moving site from localhost to webserver

Post Reply
Guru42
Jr. Bludit
Posts: 3
Joined: Mon Jun 10, 2019 7:15 pm

Mon Jun 10, 2019 7:20 pm

Moving site from localhost to webserver - links break - can't long into admin

Would be nice to edit and develop on localhost and move to internet webserver when completed.

Tried an install on the internet webserver to look for domain references, and then move site to local, but see no quick and easy fix.

Any ideas would be appreciated.
User avatar
Edi
Site Admin
Posts: 1624
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Mon Jun 10, 2019 7:26 pm

Guru42 wrote:
Mon Jun 10, 2019 7:20 pm
Tried an install on the internet webserver to look for domain references, and then move site to local, but see no quick and easy fix.
And what exactly is the problem? Have you changed the URL in the admin panel after moving to localhost?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Guru42
Jr. Bludit
Posts: 3
Joined: Mon Jun 10, 2019 7:15 pm

Mon Jun 10, 2019 7:33 pm

installed on webserver - copied to localhost

--> Page not found | Hey! looks like the page doesn't exist.
--> Object not found!

The requested URL was not found on this server. The link on the referring page seems to be wrong or outdated. Please inform the author of that page about the error.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
Apache/2.4.35 (Win32) OpenSSL/1.1.0i PHP/7.2.11

RE: >>> Have you changed the URL in the admin panel after moving to localhost?

I can't get to admin panel
Guru42
Jr. Bludit
Posts: 3
Joined: Mon Jun 10, 2019 7:15 pm

Mon Jun 10, 2019 8:36 pm

I did a fresh install on the localhost, left the Site URL blank, and edited the .htacces file to # Base directory RewriteBase /

And the site uploaded is allowing me access to admin

------

However in the reverse direction, a site set up on the webserver, I still haven't figured out the magic to get the site to work when downloaded on the localhost. Using the same process, set the the Site URL blank, and edited the .htacces file to # Base directory RewriteBase / I am getting Error 404 - localhost - Apache/2.4.35 (Win32) OpenSSL/1.1.0i PHP/7.2.11

------


It is a bit frustrating, I have used other flat file CMS on my localhost and uploaded and downloaded without issue. It feels like there is some config information embedded somewhere that I need to find.
User avatar
Edi
Site Admin
Posts: 1624
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Mon Jun 10, 2019 8:38 pm

Guru42 wrote:
Mon Jun 10, 2019 7:33 pm
I can't get to admin panel
You can change the settings in the file site.php in the directory /bl-content/databases/.
Guru42 wrote:
Mon Jun 10, 2019 8:36 pm
I did a fresh install on the localhost, left the Site URL blank, and edited the .htacces file to # Base directory RewriteBase /
What do you mean with "left the Site URL blank"?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
Jay
Master Bludit
Posts: 73
Joined: Mon Feb 11, 2019 8:41 pm

Wed Jun 12, 2019 4:05 pm

Try to make a backup of content using backup plugin, install a fresh instance on your webserver, and then upload the backuped content.

Have on mind, that
- all the links you paste in editor are absolute by default
- cms settings needs to be adjusted
Post Reply