Cachy is incompatible with the search plugin

User avatar
RalfKerkhoff
Ssr. Bludit
Posts: 17
Joined: Sun Jan 03, 2021 11:16 am

Update - found a soution:

In Bludit's settings under the advanced tab, the pages are set to "/" wich means articles are displayed in the frontend like:
https://yoursite.com/articlename

Solution:
change the "/" to something like "/articles/" (without the quotes). Articles will now be displayed as:
https://yoursite.com/articles/articlename

Doing so will make the search work with :
Cachy
simple stats plus

Cheers
Ralf
roy
Jr. Bludit
Posts: 1
Joined: Thu Sep 23, 2021 2:54 pm

my working solution is put new line like this , in the beginning of cachy3/plugin php script:

Code: Select all

<?php
if(!strpos((strtolower($_SERVER['REQUEST_URI'])), "search")){



/**
 *  Cachy
 *
 *  @package Bludit
 *  @subpackage Plugins
 *  @author PB-Soft - Patrick Biegel
 *  @copyright 2019 PB-Soft
 *  @version 3.1
 *  @release 2019-07-03
 *
 */
etc ...

and then,
close the script with a new

Code: Select all

 }
in the very last line of cachy3/plugin.php script.

the search page running normally and the cachy plugin also running normally.

I hope someone will includes this trick into the cachy3 next release.
P.S :
I DO NOT change "page" setting in SETTING GENERAL ADVANCE URL FILTERS Advanced tab.
Post Reply