RSS und Sitemap

Post Reply
User avatar
PEN
Ssr. Bludit
Posts: 11
Joined: Tue Jan 09, 2018 11:05 am
Location: St. Gallen
Contact:

Tue Jan 09, 2018 11:10 am

Hallo

Auf meinem Webserver bekomme ich immer wieder folgende Fehler im Log:

[09-Jan-2018 10:51:40 Europe/Zurich] (2.1.1) (/rss.xml) Plugin::webhook | Webhook requested.
[09-Jan-2018 10:51:44 Europe/Zurich] (2.1.1) (/sitemap.xml) Plugin::webhook | Webhook requested.
[09-Jan-2018 11:02:12 Europe/Zurich] (2.1.1) (/rss-feed.xml) buildPage | Error occurred when trying build the page from file with key: rss-feed.xml
[09-Jan-2018 11:02:12 Europe/Zurich] (2.1.1) (/rss-feed.xml) buildPage | Error occurred when trying build the page from file with key:

Was kann ich dagegen machen?
Danke und Gruss
PEN
User avatar
Edi
Site Admin
Posts: 1253
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Jan 09, 2018 11:39 am

Welches Theme verwendest Du?

Was für einen Webserver?

Und: Handelt es sich um eine Neuinstallation von Bludit oder ein eine aktualisierte Version?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
PEN
Ssr. Bludit
Posts: 11
Joined: Tue Jan 09, 2018 11:05 am
Location: St. Gallen
Contact:

Tue Jan 09, 2018 11:59 am

Hallo

Thema ist "editorial".
Es handelt sich um die neuste Bludit Version 2.1.1 . Pro.
Mein Provider ist VIVANET.

Noch was:
Im Template wird der Befehl "if (pluginEnabled('sitemap'))" verwendet, was aber nicht funktioniert.

Nachtrag:
Mit "if( $plugins['all']['pluginSitemap']->installed() )" funktioniert es wie es sollte.

PEN
User avatar
Edi
Site Admin
Posts: 1253
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Jan 09, 2018 5:04 pm

Funktioniert es nun?

Wo hast Du das Theme heruntergeladen? Ich kann das Problem mit den offiziellen Downloads nicht reproduzieren...
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
PEN
Ssr. Bludit
Posts: 11
Joined: Tue Jan 09, 2018 11:05 am
Location: St. Gallen
Contact:

Wed Jan 10, 2018 10:30 am

Nachdem ich bei meinem Provider PHP 5.6 nochmals aktiviert habe, kommen auf dem Server keine Fehlermeldungen mehr.
Thema ab offiziellem Download.

In der Index.php habe ich ab Zeile 46 "pluginEnabled('sitemap')" durch "$plugins['all']['pluginSitemap']->installed()" ersetzt. Vorher wurde das Symbol für z.B. RSS nicht angezeigt.

Danke und Gruss aus der Schweiz
Peter

P.S.:
I love Bludit :D
User avatar
Edi
Site Admin
Posts: 1253
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Wed Jan 10, 2018 10:34 am

Vielen Dank für die Hinweise! Wir werden das Theme anpassen.

Mit besten Grüssen zurück ins Land!

Edi
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Post Reply