Page 1 of 1

Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 1:08 pm
by lrsbmnn
Hello!

Da meine php Skills leider sehr überschaubar sind, bräuchte ich die Hilfe von Experten.

Code: Select all

<h1 class="site-title">
        <a href="<?php echo $site->url() ?>">
        <?php echo $site->logo() ?>
        </a>
</h1>
Hier habe ich die eigentliche title Referenz auf logo geändert, um anstatt des Titels das hochgeladene Logo dargestellt zu bekommen. Leider bekomme ich jetzt den Link des Logos angezeigt. :D Hat da eventuell jemand eine Idee?

Desweiteren benutze ich das link Plugin in der Sidebar. Hier hab ich ein rein darstellerisches Problem bei dem vor jedem einzelnen Link ein "Listenpunkt" dargestellt wird.

https://imgur.com/bCD91NJ

Gibts einen Weg diese zu entfernen?

Danke & Grüße!

Lars

Re: Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 1:38 pm
by Edi
lrsbmnn wrote:
Fri Jul 31, 2020 1:08 pm
Leider bekomme ich jetzt den Link des Logos angezeigt.
Für die Einbindung des Logos müsstest Du verwenden:

Code: Select all

<img src="<?php echo $site->logo() ?>">

Desweiteren benutze ich das link Plugin in der Sidebar. Hier hab ich ein rein darstellerisches Problem bei dem vor jedem einzelnen Link ein "Listenpunkt" dargestellt wird.

https://imgur.com/bCD91NJ

Gibts einen Weg diese zu entfernen?
Aktiviere das Plugin HTML-Code und gib das Folgende in das Feld "Head" ein:

Code: Select all

<script>
.plugin ul {
   list-style: none !important;
   padding: 0 !important;
}
</script>

Re: Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 3:14 pm
by lrsbmnn
Danke dir! Ersteres hat schonmal wunderbar funktioniert! :) (wieder was gelernt) Nur beim zweiten Problem ändert sich irgendwie nichts, wenn ich den Code einbinde.

https://imgur.com/gwwzbd3

So sollte es doch aussehen, oder?

Grüße

Re: Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 4:22 pm
by Edi
Das ist abhängig vom Theme. Ich habe Dir einfach eine Standardlösung gegeben in der Hoffnung, dass sie funktioniert. ;-)

Welches Theme verwendest Du?

Re: Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 4:46 pm
by lrsbmnn
Welches Theme verwendest Du?
Ahhhh sorry! :D Ich war bis eben fester Überzeugung das würde in meinem ersten Post stehen. Ich verwende micro 2.1.

Re: Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 5:32 pm
by Edi
Entschuldige, ich habe Dir einen Mist angegeben. Es muss selbstverständlich <style> verwendet werden statt <script>. Und !important braucht es nicht.

Also:

Code: Select all

<style>
.plugin ul {
   list-style: none;
   padding: 0;
}
</style>

Re: Probleme mit Sidebar Logo und Links Plugin

Posted: Fri Jul 31, 2020 6:12 pm
by lrsbmnn
Entschuldige, ich habe Dir einen Mist angegeben. Es muss selbstverständlich <style> verwendet werden statt <script>. Und !important braucht es nicht.
Yes Sir! Alle Probleme behoben. :) Nochmal vielen Dank!