Probleme bei/nach Installation

Post Reply
motogutzi
Jr. Bludit
Posts: 2
Joined: Tue Feb 12, 2019 6:09 pm

Tue Feb 12, 2019 6:21 pm

Hallo,

ich wollte Bludit gerne mal ausprobieren.
Ich habe dazu unter Windows 10 den IIS aktiviert, PHP installiert, bludit runtergeladen, mbstring aktiviert und gd2 aktiviert.
den inhalt aus der bludit-zip in den Ordner wwwroot\bludit entpackt.

Im IIS habe ich unter Standarddokument "index.php" eingetragen.
Danach habe ich dann im browser localhost\bludit aufgerufen, woraufhin auch die installationsseite aufgerufen wurden. Sprache ausgewählt, Kennwort eingeben, fertiggstellt.

Wenn ich danach localhost\bludit wieder aufrufe kommt eine schmucklose Seite mit folgendem Inhalt:

BLUDIT

Über
Github Github
Twitter Twitter
Facebook Facebook

Willkommen bei Bludit

Gratulation, Bludit wurde erfolgreich installiert!
Veröffentliche deine Inhalte

Veröffentliche deine eigenen Inhalte oder passe die vorhandenen deinen Bedürfnissen an. Um Inhalte zu veröffentlichen, zu bearbeiten oder zu löschen, musst du dich im Administrationsbereich anmelden (mit dem Benutzernamen admin und dem Passwort, das Du bei der Installation eingegeben hast).
Richte deine Website ein

Passe die Einstellungen deiner Website im Administrationsbereich an. Unter Einstellungen > Allgemein kannst Du beispielsweise den Titel und die Beschreibung der Website ändern oder Links zu sozialen Netzwerken eingeben.
Folge Bludit

Halte dich auf dem Laufenden über neue Versionen, Themes und Plugins in den sozialen Netzwerken Facebook, Twitter und YouTube, über den Blog oder indem du den deutschsprachigen Newsletter abonnierst.

Copyright © 2019Powered byBludit


Hier sind schon keine Bilder geladen; unter bei Powered byBludit sieht es aber z.B. so aus, als ob eins hingehört.

alle Links zur internen Seite, z.B. http://localhost/bludit/veroeffentliche-deine-inhalte funktionieren nicht. hier kommt immer eine Fehlermeldung vom IIS:

HTTP-Fehler 404.0 - Not Found
Die gesuchte Ressource wurde entfernt oder umbenannt, oder sie steht vorübergehend nicht zur Verfügung.


Habt Ihr eine Idee, was ich noch einstellen muss? Ich vermute im IIS ist noch etwas nicht korrekt...

Vielen Dank, motogutzi.
User avatar
Edi
Site Admin
Posts: 1544
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Feb 12, 2019 8:01 pm

IIS-Installationen sind meistens nicht ganz einfach... Bei Bludit musst Du die Datei .htaccess IIS anpassen in der Art von:

Code: Select all

<rules> 
   <rule name="Rule1" stopProcessing="true">
      <match url="^(.*)$" ignoreCase="false" />
         <conditions>
            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
            <add input="{URL}" pattern="^/favicon.ico$" ignoreCase="false" negate="true" />
         </conditions>
      <action type="Rewrite" url="index.php?q={R:1}" appendQueryString="true" />
   </rule>
</rules>
</rewrite>
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
motogutzi
Jr. Bludit
Posts: 2
Joined: Tue Feb 12, 2019 6:09 pm

Tue Feb 12, 2019 8:22 pm

Hallo,

das hat leider nicht geholfen. ich glaube in dem quelltext ist das </rewrite> auch zu viel, oder?

anbei der code aus meiner .htaccess:

Code: Select all

AddDefaultCharset UTF-8

<IfModule mod_rewrite.c>

# Enable rewrite rules
RewriteEngine on

# Base directory
RewriteBase /bludit/

# Deny direct access to the next directories
RewriteRule ^bl-content/(databases|workspaces|pages|tmp)/.*$ - [R=404,L]

# All URL process by index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*) index.php [PT,L]

<rules> 
   <rule name="Rule1" stopProcessing="true">
      <match url="^(.*)$" ignoreCase="false" />
         <conditions>
            <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" negate="true" />
            <add input="{URL}" pattern="^/favicon.ico$" ignoreCase="false" negate="true" />
         </conditions>
      <action type="Rewrite" url="index.php?q={R:1}" appendQueryString="true" />
   </rule>
</rules>

</IfModule>
Sollte das doch anders aussehen?

Gruß, motogutzi.
User avatar
Edi
Site Admin
Posts: 1544
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Feb 12, 2019 8:30 pm

Ich bin leider kein Server-Experte... Den Code habe ich aus dem Bludit-Chat, in dem das Problem vor einiger Zeit diskutiert worden ist. Am einfachsten ist es, wenn Du dort nachfragst:

https://gitter.im/bludit/support

Dort können Dir @dimobelov und @anaggh sicher weiterhelfen.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Post Reply