Pfad-Problem

Post Reply
bzdega
Jr. Bludit
Posts: 1
Joined: Thu Sep 20, 2018 3:09 pm

Thu Sep 20, 2018 3:20 pm

Hi,

ich habe gerade meine Bludit-Installation fertiggestellt und bin bei der Erstellung der ersten Inhalte. Dabei ist mir aufgefallen, dass die URL nicht richtig ist.

Das CMS ist installiert unter https://domain.tld/blog/, wenn ich die Seite Adresse aufrufe, wird jedoch direkt auf https://domain.tld/domain/blog/ weitergeleitet.

In den Einstellungen ist folgendes eingetragen:
- Adresse der Website: https//domain.tld

URL-Filter:

Seiten: /
Schlagwörter: /tag/
Kategorie: /category/
Blog: /
Ich vermutete schon einen Fehler in der .htaccess (RewriteBase), aber meine Änderungsversuche waren nicht erfolgreich:

Code: Select all

AddDefaultCharset UTF-8

<IfModule mod_rewrite.c>

# Enable rewrite rules
RewriteEngine on

# Base directory
RewriteBase /blog/

# Deny direct access to .txt files
RewriteRule ^bl-content/(.*)\.txt$ - [R=404,L]

# All URL process by index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*) index.php [PT,L]

</IfModule>
Jemand eine Idee dazu?

Gruß

Michael
User avatar
Edi
Site Admin
Posts: 1257
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Thu Sep 20, 2018 5:12 pm

Was hast Du als URL der Website in den Einstellungen angegeben?

Ob als RewriteBase ein Verzeichnis angegeben werden muss, ist von den Server-Einstellungen abhängig.

Du kannst mir auch gerne eine PM schreiben, dann schaue ich mir das an.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Post Reply