Bild-URL - Pfad nicht korrekt

Post Reply
peterdot
Jr. Bludit
Posts: 8
Joined: Wed Jun 20, 2018 2:29 pm

Mon Jul 16, 2018 5:01 pm

Ich habe mit dem Standard-Editor wie auch mit Tiny versucht, ein Bild in einen Post einzufügen. In beiden Fällen wird eine URL erzeugt, die so aussieht:
Image

Der Pfad "testbild.jpg" wird nicht korrekt auf "http://meinedomain.com/blog/bl-content/ ... stbild.jpg" aufgelöst. Daher wird das Bild nicht angezeigt.

Hat es da ein Problem mit der .htaccess? Oder wie muss Bludit konfiguriert werden, damit keine absoluten Bilder-Pfade angegeben werden müssen? So wie ich das sehe, hat Bludit nur eine Konfiguration für den Pfad zu Seiten, Kategorien usw. aber nicht zu den Uploads.

Danke für eure Hilfe. ;)
Attachments
16-07-_2018_16-55-13.png
16-07-_2018_16-55-13.png (7.31 KiB) Viewed 702 times
User avatar
Edi
Site Admin
Posts: 1261
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Mon Jul 16, 2018 5:42 pm

Wo ist Bludit installiert? Im Unterverzeichnis /blog?

Wenn Bludit im Unterverzeichnis /blog installiert ist, kannst Du die Datei .htaccess wie folgt anpassen (Zeile 8):

Code: Select all

# Base directory
RewriteBase /blog/
Abhängig von der Konfiguration des Servers muss die .htaccess manchmal ergänzt werden.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
peterdot
Jr. Bludit
Posts: 8
Joined: Wed Jun 20, 2018 2:29 pm

Tue Jul 17, 2018 9:22 am

Hallo Edi,

danke für deine Anregung. Ja genau, Bludit ist nicht im www root, sondern in einem Unterordner "blog" installiert.

Jetzt ist es aber so, dass meine One-Page Bootstrap Seite im Root liegt. Sprich die Domain beispiel.de zeigt auf die Index-Datei der One-Page.

Bludit verwende ich nur für den Blog. Daher möchte ich, dass Bludit nur im Subverzeichnis beispiel.de/blog aufgerufen werden kann. Wenn ich jetzt aber folgendes zur .htaccess hinzufüge:

# Base directory
RewriteBase /blog/

dann wird meinem Verständnis nach Bludit unter der Adresse beispiel.de aufrufbar (das "blog" subverzeichnis wird einfach aus der URL ausgeschnitten). Das möchte ich nicht.

Also was ich brauche:
-Meine One-Page-Homepage im Root
- Bludit (ausschließlich für den Blog) unter /blog aufrufbar

Hoffe das ist verständlich beschrieben.
LG und danke
peterdot
Jr. Bludit
Posts: 8
Joined: Wed Jun 20, 2018 2:29 pm

Tue Jul 17, 2018 10:04 am

Zusatz:
wenn ich die Bild-URL von "testbild.jpg" auf "bl-content/uploads/testbild.jpg" ändere, dann wird das Bild angezeigt.
User avatar
Edi
Site Admin
Posts: 1261
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Jul 17, 2018 11:59 am

peterdot wrote:
Tue Jul 17, 2018 9:22 am
Wenn ich jetzt aber folgendes zur .htaccess hinzufüge:

# Base directory
RewriteBase /blog/

dann wird meinem Verständnis nach Bludit unter der Adresse beispiel.de aufrufbar (das "blog" subverzeichnis wird einfach aus der URL ausgeschnitten).
Nein, damit würde das Verteichnis /blog zum Hauptverzeichnis von Bludit erklärt.

Hast Du es versucht?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
peterdot
Jr. Bludit
Posts: 8
Joined: Wed Jun 20, 2018 2:29 pm

Tue Jul 17, 2018 12:40 pm

Hallo,

ja habe ich versucht, ohne Erfolg. Es ändert nichts.
Interessanterweise werden alle sonstigen Pfade ja korrekt aufgelöst (mit oder ohne RewriteBase).

Zur die URLS im Post-Content werden nicht korrekt mit dem Pfad versehen.
User avatar
Edi
Site Admin
Posts: 1261
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Jul 17, 2018 2:45 pm

1) Verwendest Du den Editor SimpleMDE? Mit welchem Code fügtst Du die Bilder ein?

2) Was steht in der .htaccess im Root-Verzeichnis? Verwendest Du ein CMS für die One-Page-Installation?

3) Bei welchem Hoster ist der Blog eingerichtet?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
peterdot
Jr. Bludit
Posts: 8
Joined: Wed Jun 20, 2018 2:29 pm

Tue Jul 24, 2018 1:00 pm

Edi wrote:
Tue Jul 17, 2018 2:45 pm
1) Verwendest Du den Editor SimpleMDE? Mit welchem Code fügtst Du die Bilder ein?

2) Was steht in der .htaccess im Root-Verzeichnis? Verwendest Du ein CMS für die One-Page-Installation?

3) Bei welchem Hoster ist der Blog eingerichtet?
Simple MDE

Im Root Verzeichnis ist eine eigene .htaccess mit folgendem Inhalt:

Code: Select all

AddDefaultCharset UTF-8

RewriteEngine on
RewriteRule ^([^\.]+)$ $1.html [NC,L]
Kein CMS für die One-Page, sondern ein simples Template auf Bootsrap-Basis.

Der Hoster ist easyname.
User avatar
Edi
Site Admin
Posts: 1261
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Jul 24, 2018 1:30 pm

Ich habe das mit einer Test-Installation durchgespielt und keine Probleme. Es scheint also möglicherweise mit der Server-Konfiguration des Hosters zusammenzuhängen.

Du kannst mir die Adresse der Website in einer PM schicken. Ich würde mir das gerne anschauen.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
User avatar
Edi
Site Admin
Posts: 1261
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Tue Jul 31, 2018 11:07 pm

Das Problem wurde inzwischen gelöst beziehungsweise die Ursache dafür gefunden.

Zur Information: Die fehlende Pfadangabe ist die Folge eines Bugs des Plugins Parsedown Extra. Wird dieses deaktiviert, funktioniert alles.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
Post Reply