The search plugin is broken!

Post Reply
rahuldottech
Ssr. Bludit
Posts: 16
Joined: Fri Sep 22, 2017 8:13 pm

Fri Jan 04, 2019 4:47 pm

I'm using the Striped-2.0 theme with the latest version of Bludit (freshly installed today).

This is the error I get when I put in a search query:

Code: Select all

[04-Jan-2019 21:12:34 Asia/Kolkata] PHP Warning:  Unsupported declare 'strict_types' in /rahul.tech/bl-plugins/search/vendors/fuzz.php on line 1
[04-Jan-2019 21:12:34 Asia/Kolkata] PHP Catchable fatal error:  Argument 2 passed to Fuzz::__construct() must be an instance of int, integer given, called in /rahul.tech/bl-plugins/search/plugin.php on line 190 and defined in /rahul.tech/bl-plugins/search/vendors/fuzz.php on line 35
This is the default search plugin, that I activated from settings.
User avatar
diego
Site Admin
Posts: 658
Joined: Sat May 16, 2015 2:53 pm
Contact:

Fri Jan 04, 2019 11:20 pm

Hi,
yes is a known issue, because the library is compatible with PHP 7, are you using PHP 5 ?

https://github.com/bludit/bludit/issues/889

Here is the fix:
https://github.com/bludit/bludit/pull/899
rahuldottech
Ssr. Bludit
Posts: 16
Joined: Fri Sep 22, 2017 8:13 pm

Sat Jan 05, 2019 5:12 am

Hey, thanks! Yeah, I haven't yet migrated to PHP 7.

Also, thanks for all the work you put into Bludit. I love it.
Post Reply