verzeichnis/url fuckup

Post Reply
peterh
Jr. Bludit
Posts: 3
Joined: Thu Mar 29, 2018 12:01 pm

Thu Mar 29, 2018 12:14 pm

Hi,

bludit liegt in einem Userverzeichnis mit Tilde "server.com/~username"
Mir wird kein Theme angezeigt und die Startseite die lokal noch funktioniert hat sieht nach dem Upload so aus: "Es sieht so aus, als würde es diese Seite nicht geben!"

in der site.php habe ich folgendes stehn:

Code: Select all

    "url": "https:\/\/server.org\/\~user\/",
wie muss ich die Url anpassen damit die Seite richtig angezeigt wird?

grüße
peter
Last edited by peterh on Thu Mar 29, 2018 2:19 pm, edited 1 time in total.
User avatar
Edi
Site Admin
Posts: 1129
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Thu Mar 29, 2018 1:52 pm

Der Eintrag ist so richtig.

Ist die Datei .htaccess auf dem Server vorhanden?

Ist mod_rewrite oder das entsprechende Modul aktiviert?
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
peterh
Jr. Bludit
Posts: 3
Joined: Thu Mar 29, 2018 12:01 pm

Thu Mar 29, 2018 2:13 pm

.htaccess

Code: Select all

AddDefaultCharset UTF-8

<IfModule mod_rewrite.c>

# Enable rewrite rules
RewriteEngine on
RewriteBase /

# Deny direct access to .txt files
RewriteRule ^bl-content/(.*)\.txt$ - [R=404,L]

# All URL process by index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*) index.php [PT,L]

</IfModule>
der server läuft mit nginx. gibts in bludit irgendwo ne fehlermeldung wenn das nicht richtig konfiguriert ist?
User avatar
Edi
Site Admin
Posts: 1129
Joined: Sun Aug 09, 2015 5:01 pm
Location: Zurich
Contact:

Thu Mar 29, 2018 2:50 pm

Versuche es bitte mit folgender Anweisung:

Code: Select all

RewriteBase /~user
Normalerweise funktioniert die mitgelieferte Datei .htaccess für Unterverzeichnisse. Es gibt aber Serverkonfigurationen, bei denen sie angepasst werden muss.
Planet Bludit, Tipps, Snippets und nützliche Links. - Newsletter, Informationen zu Bludit (auf Deutsch).
peterh
Jr. Bludit
Posts: 3
Joined: Thu Mar 29, 2018 12:01 pm

Mon Apr 09, 2018 10:21 pm

Cool das hat funktioniert. Danke!

Das Theme wird leider immer noch nicht richtig angezeigt :P
Hab jetzt auch noch die Adresse unter /admin/settings-advanced/ angepasst.
Post Reply